summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2023-03-14 08:49:38 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2024-08-05 11:03:03 +0200
commit14e637a8d015911c5c60b07fdb34b9ba091bdeb6 (patch)
treefa14f03c3d9d7052d1c778ea2d04da25ea762dd1 /src/Makefile.am
parentb08347e31619f88969879abe21683bc42fb31100 (diff)
Enable out-of-tree builds
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am134
1 files changed, 67 insertions, 67 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 279ad05..d9a3a90 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,88 +3,88 @@
bin_PROGRAMS = dgedit
dgedit_LDADD = $(SNDFILE_LIBS) $(QT_LIBS) $(AO_LIBS) \
- $(shell ../tools/MocList o ) qrc_dgedit.o
+ $(shell $(top_srcdir)/tools/MocList $(top_srcdir)/src o ) qrc_dgedit.o
dgedit_CXXFLAGS = -g $(SNDFILE_CXXFLAGS) $(QT_CFLAGS) $(AO_CFLAGS) \
- -DLOCALEDIR='"$(localedir)"'
+ -DLOCALEDIR='"$(localedir)"' -I$(top_srcdir)
AM_CXXFLAGS = $(QT_CFLAGS)
dgedit_TRANSLATIONS = \
- ts/dgedit_da.ts \
- ts/dgedit_fr.ts
+ $(top_srcdir)/src/ts/dgedit_da.ts \
+ $(top_srcdir)/src/ts/dgedit_fr.ts
dgedit_SOURCES = \
- dgedit.cc \
- aboutdialog.cc \
- audioextractor.cc \
- canvas.cc \
- canvastool.cc \
- canvastoollisten.cc \
- canvastoolselections.cc \
- canvastoolthreshold.cc \
- canvaswidget.cc \
- channeldialog.cc \
- channelswidget.cc \
- filelist.cc \
- imageeditor.cc \
- instrumentdialog.cc \
- instrumentwidget.cc \
- itemeditor.cc \
- localehandler.cc \
- mainwindow.cc \
- mipmap.cc \
- player.cc \
- project.cc \
- projectdialog.cc \
- projectrenderer.cc \
- projectserialiser.cc \
- renderdialog.cc \
- samplesorter.cc \
- selection.cc \
- selectioneditor.cc \
- settings.cc \
- volumefader.cc \
- zoomslider.cc
+ $(top_srcdir)/src/dgedit.cc \
+ $(top_srcdir)/src/aboutdialog.cc \
+ $(top_srcdir)/src/audioextractor.cc \
+ $(top_srcdir)/src/canvas.cc \
+ $(top_srcdir)/src/canvastool.cc \
+ $(top_srcdir)/src/canvastoollisten.cc \
+ $(top_srcdir)/src/canvastoolselections.cc \
+ $(top_srcdir)/src/canvastoolthreshold.cc \
+ $(top_srcdir)/src/canvaswidget.cc \
+ $(top_srcdir)/src/channeldialog.cc \
+ $(top_srcdir)/src/channelswidget.cc \
+ $(top_srcdir)/src/filelist.cc \
+ $(top_srcdir)/src/imageeditor.cc \
+ $(top_srcdir)/src/instrumentdialog.cc \
+ $(top_srcdir)/src/instrumentwidget.cc \
+ $(top_srcdir)/src/itemeditor.cc \
+ $(top_srcdir)/src/localehandler.cc \
+ $(top_srcdir)/src/mainwindow.cc \
+ $(top_srcdir)/src/mipmap.cc \
+ $(top_srcdir)/src/player.cc \
+ $(top_srcdir)/src/project.cc \
+ $(top_srcdir)/src/projectdialog.cc \
+ $(top_srcdir)/src/projectrenderer.cc \
+ $(top_srcdir)/src/projectserialiser.cc \
+ $(top_srcdir)/src/renderdialog.cc \
+ $(top_srcdir)/src/samplesorter.cc \
+ $(top_srcdir)/src/selection.cc \
+ $(top_srcdir)/src/selectioneditor.cc \
+ $(top_srcdir)/src/settings.cc \
+ $(top_srcdir)/src/volumefader.cc \
+ $(top_srcdir)/src/zoomslider.cc
HDRS = \
- aboutdialog.h \
- audioextractor.h \
- canvas.h \
- canvastool.h \
- canvastoollisten.h \
- canvastoolselections.h \
- canvastoolthreshold.h \
- canvaswidget.h \
- channeldialog.h \
- channelswidget.h \
- filelist.h \
- imageeditor.h \
- instrumentdialog.h \
- instrumentwidget.h \
- itemeditor.h \
- localehandler.h \
- mainwindow.h \
- mipmap.h \
- player.h \
- project.h \
- projectdialog.h \
- projectrenderer.h \
- projectserialiser.h \
- renderdialog.h \
- samplesorter.h \
- selection.h \
- selectioneditor.h \
- sleep.h \
- settings.h \
- volumefader.h \
- zoomslider.h
+ $(top_srcdir)/src/aboutdialog.h \
+ $(top_srcdir)/src/audioextractor.h \
+ $(top_srcdir)/src/canvas.h \
+ $(top_srcdir)/src/canvastool.h \
+ $(top_srcdir)/src/canvastoollisten.h \
+ $(top_srcdir)/src/canvastoolselections.h \
+ $(top_srcdir)/src/canvastoolthreshold.h \
+ $(top_srcdir)/src/canvaswidget.h \
+ $(top_srcdir)/src/channeldialog.h \
+ $(top_srcdir)/src/channelswidget.h \
+ $(top_srcdir)/src/filelist.h \
+ $(top_srcdir)/src/imageeditor.h \
+ $(top_srcdir)/src/instrumentdialog.h \
+ $(top_srcdir)/src/instrumentwidget.h \
+ $(top_srcdir)/src/itemeditor.h \
+ $(top_srcdir)/src/localehandler.h \
+ $(top_srcdir)/src/mainwindow.h \
+ $(top_srcdir)/src/mipmap.h \
+ $(top_srcdir)/src/player.h \
+ $(top_srcdir)/src/project.h \
+ $(top_srcdir)/src/projectdialog.h \
+ $(top_srcdir)/src/projectrenderer.h \
+ $(top_srcdir)/src/projectserialiser.h \
+ $(top_srcdir)/src/renderdialog.h \
+ $(top_srcdir)/src/samplesorter.h \
+ $(top_srcdir)/src/selection.h \
+ $(top_srcdir)/src/selectioneditor.h \
+ $(top_srcdir)/src/sleep.h \
+ $(top_srcdir)/src/settings.h \
+ $(top_srcdir)/src/volumefader.h \
+ $(top_srcdir)/src/zoomslider.h
EXTRA_DIST = \
$(dgedit_TRANSLATIONS) \
$(HDRS) \
dgedit.qrc
-dgedit_MOC = $(shell ../tools/MocList cc )
+dgedit_MOC = $(shell $(top_srcdir)/tools/MocList $(top_srcdir)/src cc )
BUILT_SOURCES = \
$(dgedit_MOC) \