summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am130
1 files changed, 66 insertions, 64 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a38b804..596767e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,74 +10,76 @@ dgedit_CXXFLAGS = -g $(SNDFILE_CXXFLAGS) $(QT_CFLAGS) $(AO_CFLAGS) \
AM_CXXFLAGS = $(QT_CFLAGS)
dgedit_TRANSLATIONS = \
- ts/dgedit_da.ts \
- ts/dgedit_fr.ts
+ $(top_srcdir)/src/ts/dgedit_da.ts \
+ $(top_srcdir)/src/ts/dgedit_fr.ts
dgedit_SOURCES = \
- dgedit.cc \
- aboutdialog.cc \
- audioextractor.cc \
- canvas.cc \
- canvastool.cc \
- canvastoollisten.cc \
- canvastoolselections.cc \
- canvastoolthreshold.cc \
- canvaswidget.cc \
- channeldialog.cc \
- channelswidget.cc \
- filelist.cc \
- imageeditor.cc \
- instrumentdialog.cc \
- instrumentwidget.cc \
- itemeditor.cc \
- localehandler.cc \
- mainwindow.cc \
- mipmap.cc \
- player.cc \
- project.cc \
- projectdialog.cc \
- projectrenderer.cc \
- projectserialiser.cc \
- renderdialog.cc \
- samplesorter.cc \
- selection.cc \
- selectioneditor.cc \
- settings.cc \
- volumefader.cc \
- zoomslider.cc
+ $(top_srcdir)/src/dgedit.cc \
+ $(top_srcdir)/src/aboutdialog.cc \
+ $(top_srcdir)/src/audioextractor.cc \
+ $(top_srcdir)/src/canvas.cc \
+ $(top_srcdir)/src/canvastool.cc \
+ $(top_srcdir)/src/canvastoollisten.cc \
+ $(top_srcdir)/src/canvastoolposition.cc \
+ $(top_srcdir)/src/canvastoolranges.cc \
+ $(top_srcdir)/src/canvastoolthreshold.cc \
+ $(top_srcdir)/src/canvaswidget.cc \
+ $(top_srcdir)/src/channeldialog.cc \
+ $(top_srcdir)/src/channelswidget.cc \
+ $(top_srcdir)/src/filelist.cc \
+ $(top_srcdir)/src/imageeditor.cc \
+ $(top_srcdir)/src/instrumentdialog.cc \
+ $(top_srcdir)/src/instrumentwidget.cc \
+ $(top_srcdir)/src/itemeditor.cc \
+ $(top_srcdir)/src/localehandler.cc \
+ $(top_srcdir)/src/mainwindow.cc \
+ $(top_srcdir)/src/mipmap.cc \
+ $(top_srcdir)/src/player.cc \
+ $(top_srcdir)/src/project.cc \
+ $(top_srcdir)/src/projectdialog.cc \
+ $(top_srcdir)/src/projectrenderer.cc \
+ $(top_srcdir)/src/projectserialiser.cc \
+ $(top_srcdir)/src/renderdialog.cc \
+ $(top_srcdir)/src/samplesorter.cc \
+ $(top_srcdir)/src/range.cc \
+ $(top_srcdir)/src/rangeeditor.cc \
+ $(top_srcdir)/src/settings.cc \
+ $(top_srcdir)/src/volumefader.cc \
+ $(top_srcdir)/src/zoomslider.cc
HDRS = \
- aboutdialog.h \
- audioextractor.h \
- canvas.h \
- canvastool.h \
- canvastoollisten.h \
- canvastoolselections.h \
- canvastoolthreshold.h \
- canvaswidget.h \
- channeldialog.h \
- channelswidget.h \
- filelist.h \
- imageeditor.h \
- instrumentdialog.h \
- instrumentwidget.h \
- itemeditor.h \
- localehandler.h \
- mainwindow.h \
- mipmap.h \
- player.h \
- project.h \
- projectdialog.h \
- projectrenderer.h \
- projectserialiser.h \
- renderdialog.h \
- samplesorter.h \
- selection.h \
- selectioneditor.h \
- sleep.h \
- settings.h \
- volumefader.h \
- zoomslider.h
+ $(top_srcdir)/src/aboutdialog.h \
+ $(top_srcdir)/src/audioextractor.h \
+ $(top_srcdir)/src/canvas.h \
+ $(top_srcdir)/src/canvastool.h \
+ $(top_srcdir)/src/canvastoollisten.h \
+ $(top_srcdir)/src/canvastoolposition.h \
+ $(top_srcdir)/src/canvastoolranges.h \
+ $(top_srcdir)/src/canvastoolthreshold.h \
+ $(top_srcdir)/src/canvaswidget.h \
+ $(top_srcdir)/src/channeldialog.h \
+ $(top_srcdir)/src/channelswidget.h \
+ $(top_srcdir)/src/filelist.h \
+ $(top_srcdir)/src/imageeditor.h \
+ $(top_srcdir)/src/instrumentdialog.h \
+ $(top_srcdir)/src/instrumentwidget.h \
+ $(top_srcdir)/src/itemeditor.h \
+ $(top_srcdir)/src/localehandler.h \
+ $(top_srcdir)/src/mainwindow.h \
+ $(top_srcdir)/src/mipmap.h \
+ $(top_srcdir)/src/player.h \
+ $(top_srcdir)/src/project.h \
+ $(top_srcdir)/src/projectdialog.h \
+ $(top_srcdir)/src/projectrenderer.h \
+ $(top_srcdir)/src/projectserialiser.h \
+ $(top_srcdir)/src/renderdialog.h \
+ $(top_srcdir)/src/samplesorter.h \
+ $(top_srcdir)/src/range.h \
+ $(top_srcdir)/src/rangeeditor.h \
+ $(top_srcdir)/src/sleep.h \
+ $(top_srcdir)/src/settings.h \
+ $(top_srcdir)/src/volumefader.h \
+ $(top_srcdir)/src/zoomslider.h
EXTRA_DIST = \
$(dgedit_TRANSLATIONS) \