summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2014-01-18 10:43:36 +0100
committerJonas Suhr Christensen <jsc@umbraculum.org>2014-01-18 10:43:36 +0100
commitf4635499bc96a597764f9cefb0b7b44f532e9c9b (patch)
tree1f3ef87b23db41aec7fe2b0fa5ca3feb396893c1 /configure.ac
parentfe9e38995f5a0abc196e9600c38d95385d6bf84f (diff)
Added enable-pugl as configure parameter.
Added nativewindow_pugl files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d85c345..fdabdbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,11 +36,12 @@ if test x$with_experimental == xyes; then
CXXFLAGS="$CXXFLAGS -DEXPERIMENTAL"
fi
-AC_ARG_WITH(pugl, [ --with-pugl Build with Pugl support])
-if test x$with_pugl == xyes; then
+AC_ARG_ENABLE(pugl, [ --enable-pugl Build with Pugl support])
+if test x$enable_pugl == xyes; then
AC_MSG_WARN([*** Building with pugl support!])
CXXFLAGS="$CXXFLAGS -DPUGL -lGL -lGLU -lglut"
fi
+AM_CONDITIONAL([ENABLE_PUGL], [test "x$enable_pugl" = "xyes"])
AC_ARG_WITH(test, [ --with-test Build unit tests])
if test x$with_test == xyes; then