summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-12-05 21:44:42 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-12-05 22:06:22 +0100
commit15f98dfc9858cd11d616cf1dfdd1a1e50a7a48db (patch)
tree8a92e11fe808e92fc923f5334aff1639f77aa6f8 /configure.ac
parent9ebea3a2c98fa55ede445e8b86cad7cf3312da25 (diff)
Add support for eXpat alternative; bsdxml.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8f2c71a..9124295 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,8 +517,8 @@ CPPFLAGS=""
CFLAGS="$EXPAT_CFLAGS"
LDFLAGS="$EXPAT_LDFLAGS"
LIBS=""
-AC_CHECK_HEADER(expat.h, , AC_MSG_ERROR([*** eXpat header file not found!]))
-AC_CHECK_LIB(expat, XML_ParserCreate, , AC_MSG_ERROR([*** eXpat library not found!]))
+AC_CHECK_HEADER(expat.h,, AC_CHECK_HEADER(bsdxml.h, , AC_MSG_ERROR([*** eXpat header file not found!])))
+AC_CHECK_LIB(expat, XML_ParserCreate,, AC_CHECK_LIB(bsdxml, XML_ParserCreate, , AC_MSG_ERROR([*** eXpat library not found!])))
EXPAT_CFLAGS="$CXXFLAGS $CPPFLAGS $CFLAGS"
EXPAT_LIBS="$LDFLAGS $LIBS"
CXXFLAGS="$tmp_CXXFLAGS"