summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-07-29 15:07:07 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-07-29 15:07:07 +0200
commit220e36f0f54dcb0342ba32b6325e9add2f47347c (patch)
tree9c11327d6d7661887e611a8e999f7e443a553a45 /configure.ac
parent20c9cd497cef9fab46f1e24eebe5fa98dc04a444 (diff)
Add embedded gettext support from resource.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 123e884..1151ad1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,7 @@ AC_LANG_POP([C++])
dnl ===========================
dnl Set up debug compile args if the user requested it
dnl ===========================
-AS_IF([test "x$with_debug" == "xyes"],
+AS_IF([test "x$with_debug" = "xyes"],
[AC_MSG_WARN([*** Building with debug support!])
DEBUG_FLAGS="-Wall -Werror -g $NO_UNDEFINED_PARAM"
HUGIN_PARM=""]
@@ -136,6 +136,26 @@ AC_SUBST(DEBUG_FLAGS)
CXXFLAGS="$CXXFLAGS $HUGIN_PARM"
+
+dnl ===========================
+dnl Enable/disable NLS support
+dnl ===========================
+AC_ARG_WITH([nls],
+ AS_HELP_STRING([--with-nls],
+ [Build with nls support (default nls enabled)]),
+ [],
+ [with_nls=yes])
+ AS_IF([test "x$with_nls" == "xyes"],
+ [AC_MSG_RESULT([*** Building with nls support!])
+ AC_CHECK_PROGS([XGETTEXT], [xgettext])
+ AC_CHECK_PROGS([MSGMERGE], [msgmerge])
+ AC_CHECK_PROGS([MSGFMT], [msgfmt])
+ AC_DEFINE_UNQUOTED([WITH_NLS], , [Build with nls support])],
+ [AC_MSG_WARN([*** Building without nls support!])]
+)
+AM_CONDITIONAL([WITH_NLS], [test "x$with_nls" = "xyes"])
+
+
dnl ===========================
dnl Check for GUI backend
dnl ===========================
@@ -690,6 +710,7 @@ AC_CONFIG_FILES(
plugin/Makefile
plugin/vst/Makefile
plugingui/Makefile
+ plugingui/locale/Makefile
man/Makefile
test/Makefile
test/dgreftest/Makefile