summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2019-11-15 17:37:14 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2019-11-15 17:37:14 +0100
commit2a97037fcc57415151b7f69585772d6e774c8f04 (patch)
treeafc72f7a7be506e204a445b507cc29dce4ea7519 /configure.ac
parentb5e8791cabec99138773e4dc13f8c6bb6f2701fc (diff)
Create DEBUG_FLAGS and use that in the Makefiles whenever appropriate, instead of adding -Wall -Werror directly to CXXFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ed8cc65..4e3d2ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,9 +127,10 @@ dnl Set up debug compile args if the user requested it
dnl ===========================
AS_IF([test "x$with_debug" == "xyes"],
[AC_MSG_WARN([*** Building with debug support!])
- CXXFLAGS="$CXXFLAGS -Wall -Werror -g $NO_UNDEFINED_PARAM"
+ DEBUG_FLAGS="-Wall -Werror -g $NO_UNDEFINED_PARAM"
HUGIN_PARM=""]
)
+AC_SUBST(DEBUG_FLAGS)
CXXFLAGS="$CXXFLAGS $HUGIN_PARM"