summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2017-05-06 02:05:33 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2017-05-06 02:09:52 +0200
commit2aef4762dfadeac32d549a6cf95bae96247b4a27 (patch)
treefa9237c66de19aaa331f1dc2250b193e66baa913 /configure.ac
parent7d3115c7d4d449b5774330f7e1a12ea61cd7f313 (diff)
Add support for msys in GUI detection.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c2c17ef..5de59b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,7 +143,7 @@ AS_IF([test "x$enable_gui" = "xauto"],
AS_CASE([$host_os],
[darwin*], [enable_gui="cocoa"],
[linux*|*bsd*], [enable_gui="x11"],
- [mingw*|windows*|winnt|cygwin], [enable_gui="win32"],
+ [msys|mingw*|windows*|winnt|cygwin], [enable_gui="win32"],
AC_MSG_ERROR([Your platform is not currently supported])
)]
@@ -251,7 +251,7 @@ AS_IF(
AS_CASE([$host_os],
[darwin*], [ ],
[linux*|*bsd*], [VST_CPPFLAGS="$VST_CPPFLAGS -D__cdecl="],
- [mingw*|windows*|winnt|cygwin], [ ],
+ [msys|mingw*|windows*|winnt|cygwin], [ ],
AC_MSG_ERROR([Your platform is not currently supported])
)