summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2017-04-10 14:01:20 +0200
committerGoran Mekić <meka@tilda.center>2017-04-14 20:46:01 +0200
commit35ff1d5187da4a102406e035e8d5c02922266c16 (patch)
treeac3b91fb86cb3c2a6b4e299a4d402da2e5dcebcd /configure.ac
parent21c0b85b57c68d591108d5f8efc1c2247c05c74f (diff)
Add OSS output support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 40 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 070f380..d437b0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,6 +288,7 @@ AC_ARG_ENABLE([cli],
AS_HELP_STRING([--enable-cli], [Compile the command line interface [default=yes]]),,
[enable_cli="yes"])
+
AS_IF(
[test "x$enable_cli" = "xyes"],
[enable_cli=yes
@@ -422,7 +423,44 @@ AS_IF(
have_output_wavfile=no]
)
- OUTPUT_PLUGINS="dummy alsa wavfile jackaudio"
+ dnl *** oss
+ case $host_os in
+ freebsd*)
+ enable_oss_value=yes
+ ;;
+ *)
+ enable_oss_value=no
+ ;;
+ esac
+ AC_ARG_ENABLE([output_oss],
+ AS_HELP_STRING(
+ [--disable-output-oss],
+ [Disable output oss plugin [enabled by default on FreeBSD, disabled otherwise]]),,
+ [enable_output_oss=$enable_oss_value]
+ )
+
+ AS_IF(
+ [test "x$enable_output_oss" = "xyes"],
+ [AC_MSG_CHECKING(for OSS)
+ AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE([[
+ #include <sys/soundcard.h>
+ #ifndef AFMT_S32_NE
+ # error no oss
+ #endif
+ ]])],
+ [
+ have_output_oss=yes
+ AC_MSG_RESULT(yes)
+ ],
+ [AC_MSG_FAILURE([no OSS headers found])]
+ )],
+
+ [AC_MSG_RESULT([*** output oss plugin disabled per user request ***])
+ have_output_oss=no]
+ )
+
+ OUTPUT_PLUGINS="dummy alsa wavfile jackaudio oss"
AC_SUBST(OUTPUT_PLUGINS)
dnl
@@ -448,6 +486,7 @@ AM_CONDITIONAL([HAVE_OUTPUT_DUMMY], [test "x$have_output_dummy" = "xyes"])
AM_CONDITIONAL([HAVE_OUTPUT_ALSA], [test "x$have_output_alsa" = "xyes"])
AM_CONDITIONAL([HAVE_OUTPUT_WAVFILE], [test "x$have_output_wavfile" = "xyes"])
AM_CONDITIONAL([HAVE_OUTPUT_JACKAUDIO], [test "x$have_output_jackaudio" = "xyes"])
+AM_CONDITIONAL([HAVE_OUTPUT_OSS], [test "x$have_output_oss" = "xyes"])
dnl ======================
dnl Check for sndfile