summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 14:15:10 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 14:15:10 +0100
commit73612cd92939921bc23fb3a075d875ec01164e8a (patch)
treed63e468f7332d73b587c3fe916dbe792b36a9c7d /configure.ac
parentda69cdf6227782c957393735ab43c040656d959c (diff)
Final (hopefully) fix 'no-undefined' check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b9fa1bc..7ee1ab5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,14 +77,14 @@ AC_LANG_PUSH([C++])
TMP_CXXFLAGS="$CXXFLAGS"
AC_MSG_CHECKING([whether CXX supports '-Wl,--no-undefined'])
CXXFLAGS="-Wall -Werror -Wl,--no-undefined"
-AC_LINK_IFELSE([AC_LANG_PROGRAM([])],
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
[ AC_MSG_RESULT([yes])
NO_UNDEFINED_PARAM=-Wl,--no-undefined
],
[ AC_MSG_RESULT([no])
AC_MSG_CHECKING([whether CXX supports '-Wl,-undefined,error'])
CXXFLAGS="-Wall -Werror -Wl,-undefined,error"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([])],
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
[AC_MSG_RESULT([yes])
NO_UNDEFINED_PARAM=-Wl,-undefined,error
],