summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 17:09:21 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 17:09:21 +0100
commit796882bcc5314c0bb095fcad0a6ffa30a6122bae (patch)
tree76ea31b3abc650df818573c5eaac327298781267 /configure.ac
parente5a27f071b80b808134336360b8674e589a80f7e (diff)
Check for -ffloat-store before using it in dgreftest.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ee1ab5..38e3080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,25 @@ AC_COMPILE_IFELSE(
)
AC_LANG_POP([C++])
+dnl ===========================
+dnl Check for -ffloat-store support
+dnl ===========================
+AC_LANG_PUSH([C++])
+TMP_CXXFLAGS="$CXXFLAGS"
+CXXFLAGS="-Wall -Werror -ffloat-store"
+AC_MSG_CHECKING([whether CXX supports -ffloat-store])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT([yes])
+ FLOAT_STORE="-ffloat-store"
+ ],
+ [AC_MSG_RESULT([no])
+ FLOAT_STORE=""
+ ]
+)
+AC_SUBST(FLOAT_STORE)
+CXXFLAGS="$TMP_CXXFLAGS"
+AC_LANG_POP([C++])
+
dnl ======================
dnl Init pkg-config
dnl ======================