summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-11-08 19:50:11 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-11-08 19:50:11 +0100
commita947c7defd6a0a6091b30f2eeb58e2a3fa912164 (patch)
treef91d9670335883b877ef50c2c333f10f9ed7c632 /configure.ac
parent3dcbb47b267169ec76e8b39331866961a7d93101 (diff)
Always depend on libatomic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 1 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 0dcf8c0..8f2c71a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -477,22 +477,7 @@ AC_HAVE_LIBRARY([rt],[],[])
dnl ======================
dnl Check for the atomic library
dnl ======================
-AC_MSG_CHECKING([for the need for linkage with libatomic])
-AC_LANG_PUSH([C++])
-AC_LINK_IFELSE([AC_LANG_SOURCE[
- #include <atomic>
- int main() {
- struct Test { int val; };
- std::atomic<Test> s;
- return s.is_lock_free()?1:0;
- }
- ]],
- [AC_MSG_RESULT([no])],
- [AC_MSG_RESULT([yes])
- AC_HAVE_LIBRARY([atomic],[],[])
- ]
-)
-AC_LANG_POP([C++])
+AC_HAVE_LIBRARY([atomic],[],[])
dnl ======================
dnl Check for the pthread library