summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 20:32:14 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 20:32:14 +0100
commit2e7176bc558cb03d4e7c27769bab9cd45c703332 (patch)
treef203a59c944714925d73ae2d33ad9c67d5b17070 /configure.ac
parent36630b0fa3d29c54a666d3bb00a2fac804fa7df9 (diff)
Change check for libzita-resampler to not depend on cpp name mangling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 37e3013..641f2f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,13 +351,13 @@ if test x$enable_resampler != xno; then
CXXFLAGS=""
CPPFLAGS="$ZITA_CPPFLAGS"
CFLAGS=""
- LDFLAGS="$ZITA_LDFLAGS"
+ LDFLAGS="$ZITA_LDFLAGS -lzita-resampler -lpthread"
LIBS=""
- AC_CHECK_HEADER(zita-resampler/resampler.h,
- AC_CHECK_LIB(zita-resampler, _Z28zita_resampler_major_versionv, has_zita=yes, has_zita=no),
- has_zita=no)
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([#include <zita-resampler/resampler.h>],
+ [Resampler r] ) ], has_zita=yes, has_zita=no)
ZITA_CPPFLAGS="$CXXFLAGS $CPPFLAGS $CFLAGS"
- ZITA_LIBS="$LDFLAGS $LIBS -lzita-resampler"
+ ZITA_LIBS="$LDFLAGS $LIBS"
CXXFLAGS="$tmp_CXXFLAGS"
CPPFLAGS="$tmp_CPPFLAGS"
CFLAGS="$tmp_CFLAGS"