summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-03-16 20:09:27 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-03-16 20:09:27 +0100
commit82b5f07386deef059e5ec24e38c4b3f1c964437d (patch)
tree9a73d6e4fbf68fca8d3c0d2f4016386e1c4d419d /configure.ac
parent03474227b4752c408f6e086a9e5a83364fe39d9f (diff)
Build cleanup and windows build add.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index cf3d32e..1745714 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,23 +106,23 @@ AS_IF(
dnl ======================
PKG_CHECK_MODULES(X11, x11 >= 1.0)
- GUI_CFLAGS="-DX11 $X11_CFLAGS"
+ GUI_CPPFLAGS="-DX11 $X11_CFLAGS"
GUI_LIBS="$X11_LIBS"],
[test "x$enable_gui" = "xwin32"],
[AC_MSG_RESULT([Setting gui backend to Win32])
- GUI_CFLAGS="-DWIN32"
+ GUI_CPPFLAGS="-DWIN32"
GUI_LIBS="-lgdi32 -lsetupapi -lws2_32"],
[test "x$enable_gui" = "xpugl"],
[AC_MSG_RESULT([Setting gui backend to Pugl])
- GUI_CFLAGS="-DPUGL -I../../pugl"
+ GUI_CPPFLAGS="-DPUGL -I../../pugl"
GUI_LIBS="-lGLU -lGL -lglut"],
AC_MSG_ERROR([*** No GUI backend has been selected ***])
)
-AC_SUBST(GUI_CFLAGS)
+AC_SUBST(GUI_CPPFLAGS)
AC_SUBST(GUI_LIBS)
AM_CONDITIONAL([ENABLE_PUGL], [test "x$enable_gui" = "xpugl"])
@@ -177,7 +177,7 @@ AS_IF(
VST_SOURCE_PATH="$with_vst_sources"
AC_SUBST(VST_SOURCE_PATH)
AC_SUBST(VST_CPPFLAGS)
- AC_CONFIG_FILES(vst/Makefile.mingw32)],
+ AC_CONFIG_FILES(plugin/Makefile.mingw32)],
[AC_MSG_RESULT([*** VST plugin will not be compiled ***])
enable_vst=no]