summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2019-06-16 10:47:33 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2019-06-16 10:47:33 +0200
commit25b398ea000b5529084d985bd14ed066a81578d3 (patch)
tree301d8eef0b212d60f5f5939d088f2492b5c1b3f0 /configure.ac
parent37c2ec6edd2294a31561b4cd46ded6a2b4f74e22 (diff)
Make max channnel count controllable through the configure script to make it possible to exceed the default 16.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff226d0..5d8652a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,6 +203,14 @@ AM_CONDITIONAL([ENABLE_PUGL_X11], [test "x$enable_gui" = "xpugl-x11"])
AM_CONDITIONAL([ENABLE_PUGL_WIN32], [test "x$enable_gui" = "xpugl-win32"])
AM_CONDITIONAL([ENABLE_PUGL_COCOA], [test "x$enable_gui" = "xpugl-cocoa"])
+dnl ===========================
+dnl Custom number of outputs?
+dnl ===========================
+AC_ARG_ENABLE([custom-channel-count],
+ AS_HELP_STRING([--enable-custom-channel-count[=count]], [Compile with specified number of output channels [default=16]]),,
+ [enable_custom_channel_count="16"])
+AC_DEFINE_UNQUOTED([NUM_CHANNELS], [$enable_custom_channel_count], [Number of output channels])
+
dnl ======================
dnl Compile unit tests
dnl ======================