summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-05-21 22:59:14 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2016-05-21 22:59:14 +0200
commit27521b890d08f98b61c132c26a6d2a08789e8fed (patch)
tree1bf597ebe073f399a60005ac420daaa3cf40a309 /configure.ac
parent79cd3d7b8a53dcb6bd2e32025b1c44fe5cd99b7c (diff)
Check for linkage against libatomic and librt.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 6c85c0f..0b23204 100644
--- a/configure.ac
+++ b/configure.ac
@@ -467,25 +467,25 @@ dnl Check for the rt library
dnl ======================
AC_HAVE_LIBRARY([rt],[],[])
-dnl ======================
-dnl Check for the atomic library
-dnl ======================
-AC_LINK_IFELSE(
- [AC_LANG_SOURCE[
- #include <atomic>
- int main() {
- struct Test { int val; };
- std::atomic<Test> s;
- s.is_lock_free();
- }
- ]],
- [libatomic=yes],
- [libatomic=no])
-
-if test "$libatomic" = no; then
- AC_HAVE_LIBRARY([atomic],[],[AC_MSG_ERROR(
- [Please install the GNU Atomic library])])
-fi
+#dnl ======================
+#dnl Check for the atomic library
+#dnl ======================
+#AC_LINK_IFELSE(
+# [AC_LANG_SOURCE[
+# #include <atomic>
+# int main() {
+# struct Test { int val; };
+# std::atomic<Test> s;
+# s.is_lock_free();
+# }
+# ]],
+# [needs_libatomic=yes],
+# [needs_libatomic=no])
+#
+#if test x$needs_libatomic = xno; then
+# AC_HAVE_LIBRARY([atomic],[],[AC_MSG_ERROR(
+# [Please install the GNU Atomic library])])
+#fi
dnl ======================
dnl Check for the pthread library