summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2018-06-16 18:28:52 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2018-06-16 18:47:28 +0200
commit7df4a9fce8d3008befc0718a6ea9fafdaecf3c6b (patch)
tree1d5d262186124e846ab1012def12ccc0bc5e8339 /configure.ac
parent2abc107b24f73b8c4664189c34196d9a27a3e339 (diff)
Fix semaphore test on OSX.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 456cb74..d635cf0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -641,6 +641,12 @@ CPPFLAGS="$tmp_CPPFLAGS"
CFLAGS="$tmp_CFLAGS"
LDFLAGS="$tmp_LDFLAGS"
LIBS="$tmp_LIBS"
+# Add extra (platform specific) libs for semaphore support?
+AS_CASE([$host_os],
+ [darwin*], [PTHREAD_LIBS="$PTHREAD_LIBS -framework CoreServices"],
+ [linux*|*bsd*], [],
+ [msys|mingw*|windows*|winnt|cygwin], [],
+ [])
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)