summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 11:43:55 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2016-12-10 11:43:55 +0100
commitd065221fda703034619500581b3339b7f3fc7e80 (patch)
treeaf0dc2c6394a20cc0a3a4506fc2097f06b92d906 /configure.ac
parent739678c2008f8e619e48a6dcf6d74a2aaa6a0565 (diff)
Improve 'no-undefined' check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 120944c..8befd1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,14 +75,14 @@ dnl Check for -Wl,--no-undefined or -Wl,-undefined,error support
dnl ===========================
TMP_CXXFLAGS="$CXXFLAGS"
AC_MSG_CHECKING([whether CXX supports '-Wl,--no-undefined'])
-CXXFLAGS=-Wl,--no-undefined
+CXXFLAGS="-Wall -Werror -Wl,--no-undefined"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
[ AC_MSG_RESULT([yes])
NO_UNDEFINED_PARAM=-Wl,--no-undefined
],
[ AC_MSG_RESULT([no])
AC_MSG_CHECKING([whether CXX supports '-Wl,-undefined,error'])
- CXXFLAGS=-Wl,-undefined,error
+ CXXFLAGS="-Wall -Werror -Wl,-undefined,error"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
[AC_MSG_RESULT([yes])
NO_UNDEFINED_PARAM=-Wl,-undefined,error