summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2017-01-18 18:29:40 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2017-01-18 18:29:40 +0100
commitf2665fb18a10598dd2756b3c6fa4b3e5dcec1ccd (patch)
tree823d6a7e2933979832df73ecfc64b8d5c0293156 /configure.ac
parent02ada7bcd1db666b1b26dceed96d51c215b87e6e (diff)
Add --with-lv2dir to configure and make sure we install the plugin at that location and run the unittest against it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 38e3080..ce2a46f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,10 +212,17 @@ AC_ARG_ENABLE([lv2],
AS_IF(
[test "x$enable_lv2" = "xyes"],
[enable_lv2=yes
- dnl ======================
- dnl Check for lv2core
- dnl ======================
- PKG_CHECK_MODULES(LV2, lv2 >= 1.0)],
+ dnl ======================
+ dnl Check for lv2core
+ dnl ======================
+ PKG_CHECK_MODULES(LV2, lv2 >= 1.0)
+ AC_ARG_WITH([lv2dir],
+ AS_HELP_STRING([--with-lv2dir=DIR],
+ [Use DIR as the lv2 plugin directory [default=LIBDIR/lv2]]),
+ [LV2DIR=$with_lv2dir],
+ [LV2DIR='$(libdir)/lv2'])
+ AC_SUBST(LV2DIR)
+ ],
[AC_MSG_RESULT([*** LV2 plugin will not be compiled ***])
enable_lv2=no]