summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-05-20 08:26:48 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2013-05-20 08:26:48 +0200
commita609e6895a96db134697acce266e0cb94488f60b (patch)
tree77d854e202e973349e3500b10dc36069e388105b /configure.in
parent98430d96a1d25cba36ad304fde6518e493fe3441 (diff)
Centralise jackclient code for reuse among the jack client modules. Implement most of the jackaudio output module (probably broken atm.).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index c551c84..cb3c99a 100644
--- a/configure.in
+++ b/configure.in
@@ -14,6 +14,8 @@ AM_PROG_LIBTOOL
AM_CONFIG_HEADER(config.h)
AC_STDC_HEADERS
+need_jack=no
+
dnl ======================
dnl Init pkg-config
dnl ======================
@@ -129,10 +131,7 @@ if test "x$enable_cli" = "xyes"; then
[enable_input_jackmidi="yes"])
if test "x$enable_input_jackmidi" = "xyes"; then
have_input_jackmidi=yes
- dnl ======================
- dnl Check for jack
- dnl ======================
- PKG_CHECK_MODULES(JACK, jack >= 0.120.1)
+ need_jack=yes
else
AC_MSG_RESULT([*** input jackmidi plugin disabled per user request ***])
have_input_jackmidi=no
@@ -178,10 +177,7 @@ if test "x$enable_cli" = "xyes"; then
[enable_output_jackaudio="yes"])
if test "x$enable_output_jackaudio" = "xyes"; then
have_output_jackaudio=yes
- dnl ======================
- dnl Check for jack
- dnl ======================
- PKG_CHECK_MODULES(JACK, jack >= 0.120.1)
+ need_jack=yes
else
AC_MSG_RESULT([*** output jack plugin disabled per user request ***])
have_output_jackaudio=no
@@ -390,6 +386,14 @@ else
AC_MSG_RESULT([*** Disabling SSE ***])
fi
+if test "x$need_jack" = "xyes"
+then
+ dnl ======================
+ dnl Check for jack
+ dnl ======================
+ PKG_CHECK_MODULES(JACK, jack >= 0.120.1)
+fi
+
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(CXXFLAGS)