summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-05-02 09:38:43 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2013-05-02 09:38:43 +0200
commit5de97b0e08cb2fb60b01a5d16d16e05ad21c5a59 (patch)
tree07b1d200ca551f55fc840b928fefd1964bc6be7b /configure.in
parentb0ac993673b50860b8215d0dc9ce0a0ae4b899ff (diff)
Disable hugin output if compiled without debug.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9dd92cf..32c1c1c 100644
--- a/configure.in
+++ b/configure.in
@@ -19,11 +19,14 @@ dnl Init pkg-config
dnl ======================
PKG_PROG_PKG_CONFIG(0.23)
+HUGIN_PARM="-DDISABLE_HUGIN"
AC_ARG_WITH(debug, [ --with-debug Build with debug support])
if test x$with_debug == xyes; then
AC_MSG_WARN([*** Building with debug support!])
CXXFLAGS="$CXXFLAGS -Wall -Werror -g"
+ HUGIN_PARM=""
fi
+CXXFLAGS="$CXXFLAGS $HUGIN_PARM"
dnl ======================
dnl Compile LV2 plugin