summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-01 20:28:05 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-01 20:28:05 +0100
commit7688cf531ab17562b0d984073891fae4d7d2f773 (patch)
tree98e3924078a0288620c88e494d9015ef789320e6 /configure.in
parentaa5d610c68f5b5de37caf9f37cd96498fb72bacf (diff)
Add unit tests.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8ba213d..2e73f91 100644
--- a/configure.in
+++ b/configure.in
@@ -45,6 +45,13 @@ if test x$with_pugl == xyes; then
AC_SUBST(PUGL_LIBS)
fi
+AC_ARG_WITH(test, [ --with-test Build unit tests])
+if test x$with_test == xyes; then
+ AC_MSG_WARN([*** Building unittests!])
+ AM_PATH_CPPUNIT(1.9.6)
+ AC_OUTPUT(test/Makefile)
+fi
+
dnl ======================
dnl Compile LV2 plugin
dnl ======================