summaryrefslogtreecommitdiff
path: root/dgedit/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2009-11-22 09:56:08 +0000
committerdeva <deva>2009-11-22 09:56:08 +0000
commit366701768b4e7e31e3d96071700783a49bcbd078 (patch)
treeaa8a1c9493c8f46d36ee1f3239d9b59361692139 /dgedit/Makefile.am
parent28630efa5e905f501f267e5e105d184ec5dd379a (diff)
Added editor for automated chopping up of audiofiles into samples.
Diffstat (limited to 'dgedit/Makefile.am')
-rw-r--r--dgedit/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/dgedit/Makefile.am b/dgedit/Makefile.am
new file mode 100644
index 0000000..5182fd5
--- /dev/null
+++ b/dgedit/Makefile.am
@@ -0,0 +1,36 @@
+bin_PROGRAMS = dgedit
+
+dgedit_LDADD = $(SNDFILE_LIBS) $(QT_LIBS) $(shell ../tools/MocList o )
+
+dgedit_CXXFLAGS = $(SNDFILE_CXXFLAGS) $(QT_CFLAGS)
+CXXFLAGS += $(QT_CFLAGS)
+
+dgedit_SOURCES = $(shell ../tools/MocList cc ) \
+ dgedit.cc \
+ audioextractor.cc \
+ canvas.cc \
+ mainwindow.cc
+
+EXTRA_DIST = \
+ audioextractor.h \
+ canvas.h \
+ mainwindow.h
+
+dgedit_MOC = $(shell ../tools/MocList cc )
+
+BUILT_SOURCES = $(dgedit_MOC)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+%.moc.cc: %.h
+ $(QT_MOC) -o $@ $<
+
+%.h: %.ui
+ $(QT_UIC) -o $@ $<
+
+%.cc: %.ui
+ $(QT_UIC) -o $@ -impl $*.h $<
+
+# command for creating .res file from .rc on Win32
+%.res: %.rc
+ rc $<