summaryrefslogtreecommitdiff
path: root/drumgizmo/Makefile.am
diff options
context:
space:
mode:
authorVolker Fischer <corrados>2021-02-02 19:14:09 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2021-02-02 19:14:37 +0100
commit172cc05cb1f3d2b69b15cfe94c792e042a41b274 (patch)
tree45b24202bc4d73422f8e02e3669c1768a7b4d7bb /drumgizmo/Makefile.am
parent10ed9e59b8b9aee402547d1261463e00872e03d8 (diff)
Add alsamidi iput engine.
Diffstat (limited to 'drumgizmo/Makefile.am')
-rw-r--r--drumgizmo/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/drumgizmo/Makefile.am b/drumgizmo/Makefile.am
index b3bca32..7702b2e 100644
--- a/drumgizmo/Makefile.am
+++ b/drumgizmo/Makefile.am
@@ -77,6 +77,10 @@ drumgizmo_SOURCES += input/ossmidi.cc
drumgizmo_CXXFLAGS += -DHAVE_INPUT_OSSMIDI
endif # HAVE_INPUT_OSSMIDI
+if HAVE_INPUT_ALSAMIDI
+drumgizmo_SOURCES += input/alsamidi.cc
+drumgizmo_CXXFLAGS += -DHAVE_INPUT_ALSAMIDI
+endif # HAVE_INPUT_ALSAMIDI
# Only compile jackclient.cc if at least one of the jack modules are included.
if HAVE_OUTPUT_JACKAUDIO
@@ -93,6 +97,7 @@ EXTRA_DIST = \
input/inputdummy.h \
input/test.h \
input/jackmidi.h \
+ input/alsamidi.h \
input/midifile.h \
input/ossmidi.h \
output/alsa.h \