summaryrefslogtreecommitdiff
path: root/drumgizmo/Makefile.am
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2017-05-21 11:28:12 +0200
committerGoran Mekić <meka@tilda.center>2017-12-30 15:18:26 +0100
commit5f6dacd2acd612c3ec7d069c853f808cfe9e3d00 (patch)
treed652a1df06765be019094e78c9682d7f3b07f5b3 /drumgizmo/Makefile.am
parent1e7485b7f42d64f86daf732b190ce287ef8ee33a (diff)
Add OSS MIDI input
Diffstat (limited to 'drumgizmo/Makefile.am')
-rw-r--r--drumgizmo/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/drumgizmo/Makefile.am b/drumgizmo/Makefile.am
index de5cad6..940630a 100644
--- a/drumgizmo/Makefile.am
+++ b/drumgizmo/Makefile.am
@@ -72,6 +72,11 @@ drumgizmo_SOURCES += output/oss.cc
drumgizmo_CXXFLAGS += -DHAVE_OUTPUT_OSS
endif # HAVE_OUTPUT_OSS
+if HAVE_INPUT_OSSMIDI
+drumgizmo_SOURCES += input/ossmidi.cc
+drumgizmo_CXXFLAGS += -DHAVE_INPUT_OSSMIDI
+endif # HAVE_INPUT_OSSMIDI
+
# Only compile jackclient.cc if at least one of the jack modules are included.
if HAVE_OUTPUT_JACKAUDIO
@@ -91,6 +96,7 @@ EXTRA_DIST = \
input/test.h \
input/jackmidi.h \
input/midifile.h \
+ input/ossmidi.h \
output/alsa.h \
output/jackaudio.h \
output/outputdummy.h \