summaryrefslogtreecommitdiff
path: root/drumgizmo/Makefile.am
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2016-04-03 13:22:29 +0200
committerJonas Suhr Christensen <jsc@umbraculum.org>2016-04-03 13:23:08 +0200
commit915efdcda8f5c26e1f173bd0f52cbc59aa337a03 (patch)
tree2d8719a5b351e71d0a426d155967d1c402b0f00a /drumgizmo/Makefile.am
parentc7aae008ad818f9cb453ce184673e0edf8ba4e58 (diff)
Added TestInputEngine available in cli.
Diffstat (limited to 'drumgizmo/Makefile.am')
-rw-r--r--drumgizmo/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/drumgizmo/Makefile.am b/drumgizmo/Makefile.am
index 01a69af..59eeb78 100644
--- a/drumgizmo/Makefile.am
+++ b/drumgizmo/Makefile.am
@@ -30,6 +30,11 @@ drumgizmo_SOURCES += input/inputdummy.cc
drumgizmo_CXXFLAGS += -DHAVE_INPUT_DUMMY
endif # HAVE_INPUT_DUMMY
+if HAVE_INPUT_TEST
+drumgizmo_SOURCES += input/test.cc
+drumgizmo_CXXFLAGS += -DHAVE_INPUT_TEST
+endif # HAVE_INPUT_TEST
+
if HAVE_INPUT_MIDIFILE
drumgizmo_CXXFLAGS += $(SMF_CFLAGS)
drumgizmo_LDADD += $(SMF_LIBS)
@@ -71,11 +76,13 @@ EXTRA_DIST = \
jackclient.h \
enginefactory.h \
input/inputdummy.h \
+ input/test.h \
input/jackmidi.h \
input/midifile.h \
output/alsa.h \
output/jackaudio.h \
output/outputdummy.h \
+ output/test.h \
output/wavfile.h
endif # ENABLE_CLI