summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2012-01-23 20:08:12 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2012-01-23 20:08:12 +0100
commitaf9c9091ed69394171485aa4c4814504f86f2004 (patch)
tree070b911dc8faed486c8e8829f0f41aec7d5b4350 /plugingui/Makefile.am
parent5e4cb10f72ef69d73fbd2c1bc42465c9111a4c41 (diff)
Simple image blit. New slider class. New filenamelineedit. New pixelbuffer used for drawing everything but the root window - with alpha blending...
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am34
1 files changed, 16 insertions, 18 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
index 08c2d0c..20150c5 100644
--- a/plugingui/Makefile.am
+++ b/plugingui/Makefile.am
@@ -4,36 +4,34 @@ plugingui_LDADD = $(SNDFILE_LIBS) $(PTHREAD_LIBS) $(EXPAT_LIBS) -ldl -lX11
plugingui_CXXFLAGS = $(SNDFILE_CXXFLAGS) $(PTHREAD_CFLAGS) $(EXPAT_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/src -DSTANDALONE -DX11
+include Makefile.am.plugingui
+include $(top_srcdir)/src/Makefile.am.drumgizmo
+
plugingui_SOURCES = \
- eventhandler.cc \
- globalcontext.cc \
- gui.cc \
- colour.cc \
- led.cc \
- window.cc \
- widget.cc \
- lineedit.cc \
- button.cc \
- checkbox.cc \
- combobox.cc \
- label.cc \
- painter.cc
+ $(PLUGIN_GUI_SOURCES)
+
+# $(DRUMGIZMO_SOURCES)
EXTRA_DIST = \
- event.h \
+ guievent.h \
eventhandler.h \
globalcontext.h \
- gui.h \
+ plugingui.h \
+ pixelbuffer.h \
colour.h \
+ font.h \
+ filelineedit.h \
led.h \
window.h \
widget.h \
lineedit.h \
button.h \
- checkbox.h \
- combobox.h \
label.h \
- painter.h
+ painter.h \
+ img_font.h \
+ img_back.h \
+ checkbox.h \
+ slider.h
################
# Test Section #