summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2011-10-14 18:03:51 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2011-10-14 18:03:51 +0200
commitef47c71a29292ff9114a67d782e526ac662a1f32 (patch)
treefca1dd5f56d89b46759cd8fcd0e6b9e803cf92f8 /plugingui/Makefile.am
parent068bbbba9248fc11c7c852508c916579bd2621e2 (diff)
Inital implementation of X11 plugin gui.
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
new file mode 100644
index 0000000..149f4a7
--- /dev/null
+++ b/plugingui/Makefile.am
@@ -0,0 +1,45 @@
+bin_PROGRAMS = plugingui
+
+plugingui_LDADD = $(SNDFILE_LIBS) $(PTHREAD_LIBS) $(EXPAT_LIBS) -ldl -lX11
+
+plugingui_CXXFLAGS = $(SNDFILE_CXXFLAGS) $(PTHREAD_CFLAGS) $(EXPAT_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/src -DSTANDALONE -DX11
+
+plugingui_SOURCES = \
+ eventhandler.cc \
+ globalcontext.cc \
+ gui.cc \
+ colour.cc \
+ window.cc \
+ widget.cc \
+ lineedit.cc \
+ button.cc \
+ checkbox.cc \
+ combobox.cc \
+ label.cc \
+ painter.cc
+
+EXTRA_DIST = \
+ event.h \
+ eventhandler.h \
+ globalcontext.h \
+ gui.h \
+ colour.h \
+ window.h \
+ widget.h \
+ lineedit.h \
+ button.h \
+ checkbox.h \
+ combobox.h \
+ label.h \
+ painter.h
+
+################
+# Test Section #
+################
+
+TEST_SOURCE_DEPS = ${EXTRA_DIST}
+TEST_SCRIPT_DIR = $(top_srcdir)/tools
+
+include ${TEST_SCRIPT_DIR}/Makefile.am.test
+
+include Makefile.am.test