summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2019-05-31 08:18:04 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2019-05-31 08:18:04 +0200
commitabc33d1b000ed7fbebbff9300864420fd6fb8fef (patch)
tree2e8c7d8b55c97b05f72e36679f34fb752f78ae73 /plugingui/Makefile.am
parent7e7db3fe70ee4e9b7c64eb63843914f2525b8526 (diff)
Add (working) Cocoa UI support.
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
index c4c2fa0..778d909 100644
--- a/plugingui/Makefile.am
+++ b/plugingui/Makefile.am
@@ -48,9 +48,9 @@ libdggui_la_CPPFLAGS = \
-DLODEPNG_NO_COMPILE_CPP
libdggui_la_CFLAGS =
-if ENABLE_PUGL_COCOA
+
libdggui_la_LIBTOOLFLAGS=--tag=CC
-endif
+
libdggui_la_LIBADD = \
$(GUI_LIBS) $(PTHREAD_LIBS)
@@ -125,11 +125,13 @@ nodist_libdggui_la_SOURCES += \
nativewindow_win32.cc
endif
-#if ENABLE_COCOA
-#nodist_libdggui_la_SOURCES += \
-# nativewindow_cocoa.m \
-# nativewindow_cocoa.cc
-#endif
+if ENABLE_COCOA
+nodist_libdggui_la_SOURCES += \
+ nativewindow_cocoa.mm
+
+libdggui_la_OBJCXXFLAGS = \
+ -fblocks
+endif
if ENABLE_PUGL_X11
nodist_libdggui_la_SOURCES += \