summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2017-04-20 20:16:48 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2017-04-20 20:16:48 +0200
commitc73f9e2632f9614bba748aed857e2a648126a963 (patch)
tree151bffe31dede7b17335004bad8014b3bb5b7837 /plugingui/Makefile.am
parent815d4eeae5a10bb1dbdd9e8810523644dfbadc5f (diff)
Change resource paths to be relative to the plugingui folder instead of the resources folder. Make rcgen run atomatically to re-generate resource_data.cc if one of the resource files changes.
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
index b6ece08..83789b8 100644
--- a/plugingui/Makefile.am
+++ b/plugingui/Makefile.am
@@ -1,8 +1,33 @@
noinst_PROGRAMS = plugingui rcgen
noinst_LTLIBRARIES = libdggui.la
-resource_data.cc : rcgen
- (cd resources; ../rcgen * ../../ABOUT ../../AUTHORS ../../COPYING > ../resource_data.cc)
+RES = \
+ resources/bg.png \
+ resources/bypass_button.png \
+ resources/font.png \
+ resources/fontemboss.png \
+ resources/knob.png \
+ resources/logo.png \
+ resources/png_error \
+ resources/progress.png \
+ resources/pushbutton.png \
+ resources/sidebar.png \
+ resources/slider.png \
+ resources/switch_back_off.png \
+ resources/switch_back_on.png \
+ resources/switch_front.png \
+ resources/tab.png \
+ resources/thinlistbox.png \
+ resources/topbar.png \
+ resources/toplogo.png \
+ resources/vertline.png \
+ resources/widget.png \
+ ../ABOUT \
+ ../AUTHORS \
+ ../COPYING
+
+resource_data.cc : rcgen $(RES)
+ ./rcgen $(RES) > resource_data.cc
libdggui_la_CPPFLAGS = \
$(GUI_CPPFLAGS) \