summaryrefslogtreecommitdiff
path: root/plugingui/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2017-04-16 19:29:59 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2017-04-16 20:15:19 +0200
commitea406769262b5ebd7d9f775e26a8655a6ee94d00 (patch)
treeee13d3a143d977e3ff12d864dcdd795261944669 /plugingui/Makefile.am
parent1b3d6c39ae120aa8a80a5330977d23906f87c621 (diff)
Add modal dialog primitive.
Diffstat (limited to 'plugingui/Makefile.am')
-rw-r--r--plugingui/Makefile.am69
1 files changed, 36 insertions, 33 deletions
diff --git a/plugingui/Makefile.am b/plugingui/Makefile.am
index 133c71f..8795acd 100644
--- a/plugingui/Makefile.am
+++ b/plugingui/Makefile.am
@@ -20,53 +20,54 @@ libdggui_la_LIBADD = \
$(GUI_LIBS) $(PTHREAD_LIBS)
nodist_libdggui_la_SOURCES = \
+ button.cc \
+ button_base.cc \
+ checkbox.cc \
+ colour.cc \
+ combobox.cc \
dgwindow.cc \
- plugingui.cc \
- label.cc \
+ dialog.cc \
+ directory.cc \
+ diskstreamingframecontent.cc \
+ drumkitframecontent.cc \
eventhandler.cc \
+ filebrowser.cc \
font.cc \
- window.cc \
- widget.cc \
- colour.cc \
+ frame.cc \
+ humanizerframecontent.cc \
+ image.cc \
+ imagecache.cc \
+ knob.cc \
+ label.cc \
+ layout.cc \
+ led.cc \
+ lineedit.cc \
+ listbox.cc \
+ listboxbasic.cc \
+ listboxthin.cc \
+ maintab.cc \
+ mainwindow.cc \
painter.cc \
- button_base.cc \
- button.cc \
pixelbuffer.cc \
- lineedit.cc \
- led.cc \
- checkbox.cc \
- toggle.cc \
+ pluginconfig.cc \
+ plugingui.cc \
powerbutton.cc \
- mainwindow.cc \
- drumkitframecontent.cc \
- statusframecontent.cc \
- humanizerframecontent.cc \
- diskstreamingframecontent.cc \
- slider.cc \
+ progressbar.cc \
+ resource.cc \
+ resource_data.cc \
scrollbar.cc \
+ slider.cc \
stackedwidget.cc \
+ statusframecontent.cc \
tabbutton.cc \
tabwidget.cc \
textedit.cc \
texture.cc \
texturedbox.cc \
- layout.cc \
- listbox.cc \
- listboxthin.cc \
- listboxbasic.cc \
- maintab.cc \
- knob.cc \
- filebrowser.cc \
- directory.cc \
- pluginconfig.cc \
- imagecache.cc \
- image.cc \
- combobox.cc \
- progressbar.cc \
+ toggle.cc \
verticalline.cc \
- resource.cc \
- resource_data.cc \
- frame.cc \
+ widget.cc \
+ window.cc \
lodepng/lodepng.cpp
if ENABLE_X11
@@ -106,12 +107,14 @@ rcgen_SOURCES = rcgen.cc
EXTRA_DIST = \
button.h \
+ button_base.h \
canvas.h \
checkbox.h \
colour.h \
combobox.h \
dgwindow.h \
drawable.h \
+ dialog.h \
directory.h \
eventhandler.h \
filebrowser.h \