summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSander Vocke <sandervocke@gmail.com>2024-07-25 09:09:35 +0200
committerSander Vocke <sandervocke@gmail.com>2024-07-25 11:06:32 +0200
commit624aafbc9cde2b9e83c7c278e44f19ab9e3bc9fc (patch)
treef6e2ef7329b32e4601326012221e0b5ce64a0367 /src/Makefile.am
parent019d478818950f7880d2c0f80d8fc8f963e9736b (diff)
Support curve maps in midi map file
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a8bdb59..9c83aab 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -67,7 +67,8 @@ libdg_la_SOURCES = \
$(top_srcdir)/src/midimapper.cc \
$(top_srcdir)/src/path.cc \
$(top_srcdir)/src/powerlist.cc \
- $(top_srcdir)/src/powermap.cc \
+ $(top_srcdir)/src/curvemap.cc \
+ $(top_srcdir)/src/parsecurvemap.cc \
$(top_srcdir)/src/powermapfilter.cc \
$(top_srcdir)/src/random.cc \
$(top_srcdir)/src/sample.cc \
@@ -126,7 +127,8 @@ EXTRA_DIST = \
path.h \
platform.h \
powerlist.h \
- powermap.h \
+ curvemap.h \
+ parsecurvemap.h \
powermapfilter.h \
random.h \
range.h \