summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndré Nusser <andre.nusser@googlemail.com>2020-05-02 12:21:16 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-05-02 12:32:45 +0200
commitcf790d239d4b5dfa772d5d1fdb112b8640a4a81a (patch)
tree8ddc552094fedb675d75e6082a94b2e31296d51b /src/Makefile.am
parent2cad525e2babac75395caf367449d9e9b31fcd42 (diff)
Add powermap functionality to the engine for mapping input velocities through a Monotone cubic
splines due to Steffen.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a8e5c74..09df750 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,6 +58,7 @@ libdg_la_SOURCES = \
midimapper.cc \
path.cc \
powerlist.cc \
+ powermap.cc \
random.cc \
sample.cc \
sample_selection.cc \
@@ -113,6 +114,7 @@ EXTRA_DIST = \
path.h \
platform.h \
powerlist.h \
+ powermap.h \
random.h \
range.h \
rangemap.h \