summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordeva <deva>2008-07-22 21:00:01 +0000
committerdeva <deva>2008-07-22 21:00:01 +0000
commitf6cabfe8fe888e00388a815541084b0fa332a462 (patch)
treed39301b9e194e2e58a24c92ec5526d05fa1b4a3a /src/Makefile.am
parent14309bc447960536c34a438dffb93f520dad40fa (diff)
DrumKit parser. Internal drumkit now used in events. This is the first milestone.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 472f5fe..7bcc60b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,14 +5,27 @@ drumgizmo_LDADD = $(JACK_LIBS) $(SNDFILE_LIBS)
drumgizmo_CXXFLAGS = $(JACK_CXXFLAGS) $(SNDFILE_CXXFLAGS)
drumgizmo_SOURCES = \
+ audiofile.cc \
+ channel.cc \
drumgizmo.cc \
+ drumkitparser.cc \
event.cc \
+ instrument.cc \
jackclient.cc \
midimapper.cc \
- sample.cc
+ sample.cc \
+ saxparser.cc \
+ velocity.cc
EXTRA_DIST = \
- jackclient.h \
+ audiofile.h \
+ channel.h \
+ drumkit.h \
+ drumkitparser.h \
event.h \
+ instrument.h \
+ jackclient.h \
midimapper.h \
- sample.h
+ sample.h \
+ saxparser.h \
+ velocity.h