summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2017-07-15 11:59:10 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2017-07-15 11:59:10 +0200
commit6a96bcf1659d07cd3a7f7e65519007abfaeda2a0 (patch)
tree47e7c7b7b7c6377fb159c864c928bbb9cefbc833 /test/Makefile.am
parentf777a1a3f5f92814f8b83fe0c22dbe461f11bed7 (diff)
Ensure that the Notifier call order is the same as the connection order.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 08ef4fa..871b3b4 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,7 +6,7 @@ if ENABLE_TESTS
TESTS = resource enginetest paintertest resampler configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
memchecker randomtest atomictest syncedsettingstest imagecachetest \
- semaphoretest drumkitcreatortest bytesizeparsertest
+ semaphoretest drumkitcreatortest bytesizeparsertest notifiertest
if ENABLE_LV2
TESTS += lv2
@@ -205,4 +205,11 @@ bytesizeparsertest_SOURCES = \
bytesizeparsertest.cc \
test.cc
+notifiertest_CXXFLAGS = -DOUTPUT=\"notifiertest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src
+notifiertest_LDFLAGS = $(CPPUNIT_LIBS)
+notifiertest_SOURCES = \
+ notifiertest.cc \
+ test.cc
+
endif