summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2018-06-06 19:00:12 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2018-06-06 19:13:41 +0200
commit7418abaeb3130423bedd6bcb3cef0eb2565ed5d6 (patch)
tree4991351a7e53a0a846c1447e9fe3ffabb31b6acc /test/Makefile.am
parent718e8db44d984a97c032dccfe95e3f4707c0835a (diff)
Added unit-test for InstrumentParser.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f72e694..26ffa81 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,7 +6,8 @@ if ENABLE_TESTS
TESTS = resource enginetest paintertest resampler configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
randomtest atomictest syncedsettingstest imagecachetest \
- semaphoretest drumkitcreatortest bytesizeparsertest notifiertest
+ semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
+ instrumentparsertest
if ENABLE_LV2
TESTS += lv2
@@ -212,4 +213,14 @@ notifiertest_SOURCES = \
notifiertest.cc \
test.cc
+instrumentparsertest_CXXFLAGS = -DOUTPUT=\"instrumentparsertest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/include
+instrumentparsertest_LDFLAGS = $(CPPUNIT_LIBS) \
+ $(top_srcdir)/src/libdg.la
+instrumentparsertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ instrumentparsertest.cc \
+ scopedfile.cc \
+ test.cc
+
endif