summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 20:34:12 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2014-12-05 20:34:12 +0100
commit3b0d9e0c9c5e08b2e449aa266617fb1db86b5a22 (patch)
treef203a59c944714925d73ae2d33ad9c67d5b17070 /test/Makefile.am
parent29ec8552826f64bfa8cad01a433306886328c522 (diff)
parent2e7176bc558cb03d4e7c27769bab9cd45c703332 (diff)
Merge branch 'resample'
Add resample support.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 77a0f96..e43a6ba 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,18 +1,15 @@
# Rules for the test code (use `make check` to execute)
include $(top_srcdir)/src/Makefile.am.drumgizmo
-TESTS = engine gui
+TESTS = engine gui resampler
check_PROGRAMS = $(TESTS)
engine_CXXFLAGS = -DOUTPUT=\"engine\" $(CPPUNIT_CFLAGS) \
-I$(top_srcdir)/src -I$(top_srcdir)/include \
-I$(top_srcdir)/hugin -DDISABLE_HUGIN
-
engine_CFLAGS = -DDISABLE_HUGIN
-
engine_LDFLAGS = $(CPPUNIT_LIBS) $(DRUMGIZMO_LIBS) $(PTHREAD_LIBS)
-
engine_SOURCES = \
$(DRUMGIZMO_SOURCES) \
$(top_srcdir)/hugin/hugin.c \
@@ -24,3 +21,12 @@ gui_LDFLAGS = $(CPPUNIT_LIBS)
gui_SOURCES = \
test.cc \
gui.cc
+
+resampler_CXXFLAGS = -DOUTPUT=\"resampler\" $(CPPUNIT_CFLAGS) \
+ $(ZITA_CXXFLAGS) $(SAMPLERATE_CFLAGS) \
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN
+resampler_LDFLAGS = $(ZITA_LIBS) $(SAMPLERATE_LIBS) $(CPPUNIT_LIBS)
+resampler_SOURCES = \
+ $(top_srcdir)/src/chresampler.cc \
+ test.cc \
+ resampler.cc \ No newline at end of file