summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2016-06-02 21:00:37 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2016-06-02 21:00:37 +0200
commitab7ab9e52ab87963831f90ab25957d883878654d (patch)
tree2225a4382497889f43477429d2f6b696ce04bf8f /test/Makefile.am
parent1d6833cfcb0b5bf4890fa15b5013d7490af48f69 (diff)
New ImageCache class for reusing Image resources.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 594aa0d..1b4470d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,7 +5,7 @@ include $(top_srcdir)/src/Makefile.am.drumgizmo
TESTS = resource engine gui resampler lv2 configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
- memchecker randomtest atomictest syncedsettingstest
+ memchecker randomtest atomictest syncedsettingstest imagecachetest
check_PROGRAMS = $(TESTS)
@@ -150,3 +150,17 @@ syncedsettingstest_SOURCES = syncedsettings.cc test.cc
EXTRA_DIST = \
lv2_test_host.h
+
+imagecachetest_CXXFLAGS = -DOUTPUT=\"imagecachetest\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/plugingui -I$(top_srcdir)/hugin
+imagecachetest_LDFLAGS = $(CPPUNIT_LIBS)
+imagecachetest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/plugingui/lodepng/lodepng.cpp \
+ $(top_srcdir)/plugingui/resource_data.cc \
+ $(top_srcdir)/plugingui/resource.cc \
+ $(top_srcdir)/plugingui/image.cc \
+ $(top_srcdir)/plugingui/imagecache.cc \
+ $(top_srcdir)/plugingui/colour.cc \
+ imagecachetest.cc \
+ test.cc