summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2015-05-21 20:52:08 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2015-05-21 20:52:08 +0200
commit560c26d33c76fee45b04e92ffd36ce885c357db6 (patch)
tree0e23a759a612f9459cdc435b3ceb580d0c4ab81d /test/Makefile.am
parent16b59fe4f96d35cf2468365ae185fba389b23020 (diff)
New configfile parser with unit test.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5aaf33f..90373e1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,7 @@
# Rules for the test code (use `make check` to execute)
include $(top_srcdir)/src/Makefile.am.drumgizmo
-TESTS = engine gui resampler lv2
+TESTS = engine gui resampler lv2 configfile
check_PROGRAMS = $(TESTS)
@@ -40,3 +40,12 @@ lv2_SOURCES = \
test.cc \
lv2_test_host.cc \
lv2.cc
+
+configfile_CXXFLAGS = -DOUTPUT=\"configfile\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/hugin
+configfile_LDFLAGS = $(CPPUNIT_LIBS)
+configfile_SOURCES = \
+ $(top_srcdir)/src/configfile.cc \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ configtest.cc