summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2013-12-01 20:28:05 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2013-12-01 20:28:05 +0100
commit7688cf531ab17562b0d984073891fae4d7d2f773 (patch)
tree98e3924078a0288620c88e494d9015ef789320e6 /test/Makefile.am
parentaa5d610c68f5b5de37caf9f37cd96498fb72bacf (diff)
Add unit tests.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..77a0f96
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,26 @@
+# Rules for the test code (use `make check` to execute)
+include $(top_srcdir)/src/Makefile.am.drumgizmo
+
+TESTS = engine gui
+
+check_PROGRAMS = $(TESTS)
+
+engine_CXXFLAGS = -DOUTPUT=\"engine\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/include \
+ -I$(top_srcdir)/hugin -DDISABLE_HUGIN
+
+engine_CFLAGS = -DDISABLE_HUGIN
+
+engine_LDFLAGS = $(CPPUNIT_LIBS) $(DRUMGIZMO_LIBS) $(PTHREAD_LIBS)
+
+engine_SOURCES = \
+ $(DRUMGIZMO_SOURCES) \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ engine.cc
+
+gui_CXXFLAGS = -DOUTPUT=\"gui\" $(CPPUNIT_CFLAGS)
+gui_LDFLAGS = $(CPPUNIT_LIBS)
+gui_SOURCES = \
+ test.cc \
+ gui.cc