summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2015-11-13 19:21:31 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2015-11-13 19:21:31 +0100
commitbfdb184d349d2b8ecf4ea993793182cb32098e12 (patch)
tree40bbf053556453f8f3de87f69c3aae0a6a87f57f /test/Makefile.am
parentca384e485956059d5d427fbe07a7b2277c43680e (diff)
Refactored Resource and added unittests.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 90373e1..08dba3b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,10 +1,20 @@
# Rules for the test code (use `make check` to execute)
include $(top_srcdir)/src/Makefile.am.drumgizmo
-TESTS = engine gui resampler lv2 configfile
+TESTS = resource engine gui resampler lv2 configfile
check_PROGRAMS = $(TESTS)
+resource_CXXFLAGS = -DOUTPUT=\"resource\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/hugin
+resource_LDFLAGS = $(CPPUNIT_LIBS)
+resource_SOURCES = \
+ $(top_srcdir)/plugingui/resource.cc \
+ $(top_srcdir)/plugingui/resource_data.cc \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ resource_test.cc
+
engine_CXXFLAGS = -DOUTPUT=\"engine\" $(CPPUNIT_CFLAGS) \
-I$(top_srcdir)/src -I$(top_srcdir)/include \
-I$(top_srcdir)/hugin -DDISABLE_HUGIN