summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2015-02-15 17:26:42 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2015-02-15 17:26:42 +0100
commitd55367b36d77e3fde7303bc17585a54e26f8b017 (patch)
treef724d357254bb340be65f08018d4cdc7630aae30 /test/Makefile.am
parent40bbb48e65efc36cb2ca42b51c7e643203f16c85 (diff)
Make lv2 unittest work with < lv2-1.10. Make LV2_PATH same as lv2 plugin installdir. Use pkg-config for lilv and serd dependencies.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 779e4f4..5aaf33f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -32,8 +32,10 @@ resampler_SOURCES = \
resampler.cc
lv2_CXXFLAGS = -DOUTPUT=\"lv2\" $(CPPUNIT_CFLAGS) \
- -I/usr/include/lilv-0 -I/usr/include/serd-0
-lv2_LDFLAGS = $(CPPUNIT_LIBS) -llilv-0 -lserd-0 -lcrypto
+ `pkg-config --cflags serd-0` `pkg-config --cflags lilv-0` \
+ -DLV2_PATH=\"$(libdir)/lv2\"
+lv2_LDFLAGS = $(CPPUNIT_LIBS) `pkg-config --libs serd-0` \
+ `pkg-config --libs lilv-0` -lcrypto
lv2_SOURCES = \
test.cc \
lv2_test_host.cc \