summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-02-16 21:36:24 +0100
committerAndré Nusser <andre.nusser@googlemail.com>2020-02-23 13:45:25 +0100
commit43da08a1e3620cc296d27ef5cdf387693b063c68 (patch)
tree74f75cafd661c0748f3c5856697cec12acdb39e1 /test/Makefile.am
parentcdc96aae4393f0cba0e274efcccc95bc25c5bbdd (diff)
Fix style, minor code fixes, and add review comments.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 56d7fa3..d0f718d 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,8 @@ TESTS = resource enginetest paintertest configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
- dgxmlparsertest domloadertest configparsertest midimapparsertest
+ dgxmlparsertest domloadertest configparsertest midimapparsertest \
+ eventsdstest
EXTRA_DIST = \
dgunit.h \
@@ -259,4 +260,13 @@ midimapparsertest_SOURCES = \
midimapparsertest.cc \
dgtest.cc
+eventsdstest_CXXFLAGS = -DOUTPUT=\"eventsdstest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src
+eventsdstest_LDFLAGS =
+eventsdstest_SOURCES = \
+ $(top_srcdir)/src/events_ds.cc \
+ eventsdstest.cc \
+ dgtest.cc
+
endif