summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAndré Nusser <andre.nusser@googlemail.com>2020-05-02 12:21:16 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-05-02 12:32:45 +0200
commitcf790d239d4b5dfa772d5d1fdb112b8640a4a81a (patch)
tree8ddc552094fedb675d75e6082a94b2e31296d51b /test/Makefile.am
parent2cad525e2babac75395caf367449d9e9b31fcd42 (diff)
Add powermap functionality to the engine for mapping input velocities through a Monotone cubic
splines due to Steffen.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 001d13d..c9ece6e 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -8,7 +8,7 @@ TESTS = resource enginetest paintertest configfile audiocache \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
dgxmlparsertest domloadertest configparsertest midimapparsertest \
- eventsdstest
+ eventsdstest powermaptest
EXTRA_DIST = \
dgunit.h \
@@ -109,7 +109,7 @@ paintertest_CXXFLAGS = -DOUTPUT=\"paintertest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src -I$(top_srcdir)/plugingui \
-I$(top_srcdir)/hugin $(PTHREAD_CFLAGS)
-paintertest_LDFLAGS = $(top_srcdir)/plugingui/libdggui.la
+paintertest_LDFLAGS = $(top_builddir)/plugingui/libdggui.la
paintertest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
dgtest.cc \
@@ -167,7 +167,7 @@ syncedsettingstest_SOURCES = syncedsettings.cc dgtest.cc
imagecachetest_CXXFLAGS = -DOUTPUT=\"imagecachetest\" \
$(DEBUG_FLAGS) \
-I$(top_srcdir)/src -I$(top_srcdir)/plugingui -I$(top_srcdir)/hugin
-imagecachetest_LDFLAGS = $(top_srcdir)/plugingui/libdggui.la
+imagecachetest_LDFLAGS = $(top_builddir)/plugingui/libdggui.la
imagecachetest_SOURCES = \
$(top_srcdir)/hugin/hugin.c \
imagecachetest.cc \
@@ -270,4 +270,13 @@ eventsdstest_SOURCES = \
eventsdstest.cc \
dgtest.cc
+powermaptest_CXXFLAGS = -DOUTPUT=\"powermaptest\" \
+ $(DEBUG_FLAGS) \
+ -I$(top_srcdir)/src
+powermaptest_LDFLAGS =
+powermaptest_SOURCES = \
+ $(top_srcdir)/src/powermap.cc \
+ powermaptest.cc \
+ dgtest.cc
+
endif