summaryrefslogtreecommitdiff
path: root/test/uitests/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-05-02 13:17:18 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2020-05-02 13:17:18 +0200
commitc9134d86d393e3acba278d886482b84d3e4bf722 (patch)
treec57d51fe730dc1c5d641b0fe345275a3c82cb0da /test/uitests/Makefile.am
parent8e5b1e0b171d0e4ff326a3ff1af162805d82a3d6 (diff)
Add new PowerWidget for setting and showing control points of the powermap.
Diffstat (limited to 'test/uitests/Makefile.am')
-rw-r--r--test/uitests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/uitests/Makefile.am b/test/uitests/Makefile.am
index bd2c6d1..6a5894b 100644
--- a/test/uitests/Makefile.am
+++ b/test/uitests/Makefile.am
@@ -1,5 +1,5 @@
noinst_PROGRAMS = resizetest tabwidgettest framewidgettest \
- filebrowsertest benchmarktest
+ filebrowsertest benchmarktest powerwidgettest
resizetest_LDADD = \
$(top_builddir)/plugingui/libdggui.la \
@@ -66,4 +66,15 @@ benchmarktest_SOURCES = \
benchmarktest_resource_data.cc \
$(top_srcdir)/hugin/hugin.c
+powerwidgettest_LDADD = \
+ $(top_builddir)/plugingui/libdggui.la \
+ $(top_builddir)/src/libdg.la
+powerwidgettest_CXXFLAGS = \
+ -I$(top_srcdir)/plugingui \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/hugin
+powerwidgettest_SOURCES = \
+ powerwidgettest.cc \
+ $(top_srcdir)/hugin/hugin.c
+
EXTRA_DIST = $(RES)