summaryrefslogtreecommitdiff
path: root/test/uitests/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2020-02-29 12:01:23 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2020-02-29 12:51:26 +0100
commitdf32a5c6a6f8e204a757f68f0a61ea6f4843c569 (patch)
tree3c8de6b28649e0860d67cdb83562baaeffcd80f3 /test/uitests/Makefile.am
parente7430f3750cbfeb1bfab96273db7798cb64f7aca (diff)
Benchmark test alpha vs. no-alpha with both partial inner and edge alpha and stretched vs. no
stretched.
Diffstat (limited to 'test/uitests/Makefile.am')
-rw-r--r--test/uitests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/uitests/Makefile.am b/test/uitests/Makefile.am
index e85190f..c47af23 100644
--- a/test/uitests/Makefile.am
+++ b/test/uitests/Makefile.am
@@ -37,6 +37,15 @@ framewidgettest_SOURCES = \
framewidgettest.cc \
$(top_srcdir)/hugin/hugin.c
+RES = \
+ benchmarktest_resources/image_no_alpha.png \
+ benchmarktest_resources/image_full_alpha.png \
+ benchmarktest_resources/image_edge_alpha.png \
+ benchmarktest_resources/image_inner_alpha.png
+
+benchmarktest_resource_data.cc : $(top_srcdir)/plugingui/rcgen $(RES)
+ $(top_srcdir)/plugingui/rcgen $(RES) > benchmarktest_resource_data.cc
+
benchmarktest_LDADD = \
$(top_srcdir)/plugingui/libdggui.la $(top_srcdir)/src/libdg.la
benchmarktest_CXXFLAGS = \
@@ -45,4 +54,5 @@ benchmarktest_CXXFLAGS = \
-I$(top_srcdir)/hugin
benchmarktest_SOURCES = \
benchmarktest.cc \
+ benchmarktest_resource_data.cc \
$(top_srcdir)/hugin/hugin.c