summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ee1ab5..38e3080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,25 @@ AC_COMPILE_IFELSE(
)
AC_LANG_POP([C++])
+dnl ===========================
+dnl Check for -ffloat-store support
+dnl ===========================
+AC_LANG_PUSH([C++])
+TMP_CXXFLAGS="$CXXFLAGS"
+CXXFLAGS="-Wall -Werror -ffloat-store"
+AC_MSG_CHECKING([whether CXX supports -ffloat-store])
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT([yes])
+ FLOAT_STORE="-ffloat-store"
+ ],
+ [AC_MSG_RESULT([no])
+ FLOAT_STORE=""
+ ]
+)
+AC_SUBST(FLOAT_STORE)
+CXXFLAGS="$TMP_CXXFLAGS"
+AC_LANG_POP([C++])
+
dnl ======================
dnl Init pkg-config
dnl ======================