summaryrefslogtreecommitdiff
path: root/dgedit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dgedit/Makefile.am')
-rw-r--r--dgedit/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/dgedit/Makefile.am b/dgedit/Makefile.am
index f054539..dad5437 100644
--- a/dgedit/Makefile.am
+++ b/dgedit/Makefile.am
@@ -12,7 +12,9 @@ dgedit_SOURCES = $(shell ../tools/MocList cc ) \
filelist.cc \
itemeditor.cc \
mainwindow.cc \
- samplesorter.cc
+ samplesorter.cc \
+ dgedit.qrc \
+ dgedit_qrc.cpp
EXTRA_DIST = \
audioextractor.h \
@@ -24,7 +26,10 @@ EXTRA_DIST = \
dgedit_MOC = $(shell ../tools/MocList cc )
-BUILT_SOURCES = $(dgedit_MOC)
+dgedit_qrc.cpp: dgedit.qrc
+ rcc $< > $@
+
+BUILT_SOURCES = $(dgedit_MOC) dgedit_qrc.cpp
CLEANFILES = $(BUILT_SOURCES)