summaryrefslogtreecommitdiff
path: root/drumgizmo/input/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'drumgizmo/input/test/Makefile.am')
-rw-r--r--drumgizmo/input/test/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/drumgizmo/input/test/Makefile.am b/drumgizmo/input/test/Makefile.am
new file mode 100644
index 0000000..ca45de0
--- /dev/null
+++ b/drumgizmo/input/test/Makefile.am
@@ -0,0 +1,26 @@
+
+testsources = \
+ test.cc
+
+if HAVE_INPUT_TEST
+
+testltlibs = libtest.la
+testbuildsources = $(testsources)
+
+else
+
+testltlibs =
+testbuildsources =
+
+endif
+
+EXTRA_DIST = $(testsources)
+
+lib_LTLIBRARIES = $(testltlibs)
+
+libdir = $(INPUT_PLUGIN_DIR)
+
+INCLUDES = -I$(top_srcdir)/include
+libtest_la_LDFLAGS =
+libtest_la_LIBADD =
+libtest_la_SOURCES = $(testbuildsources)