summaryrefslogtreecommitdiff
path: root/drumgizmo/input/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'drumgizmo/input/test/Makefile.am')
-rw-r--r--drumgizmo/input/test/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/drumgizmo/input/test/Makefile.am b/drumgizmo/input/test/Makefile.am
index 0b65a67..35466ab 100644
--- a/drumgizmo/input/test/Makefile.am
+++ b/drumgizmo/input/test/Makefile.am
@@ -4,7 +4,7 @@ testsources = \
if HAVE_INPUT_TEST
-testltlibs = libtest.la
+testltlibs = test.la
testbuildsources = $(testsources)
else
@@ -21,6 +21,9 @@ lib_LTLIBRARIES = $(testltlibs)
libdir = $(INPUT_PLUGIN_DIR)
AM_CPPFLAGS = -I$(top_srcdir)/include
-libtest_la_LDFLAGS =
-libtest_la_LIBADD =
-libtest_la_SOURCES = $(testbuildsources)
+test_la_LDFLAGS = -module -avoid-version -shared
+test_la_LIBADD =
+test_la_SOURCES = $(testbuildsources)
+
+install-exec-hook:
+ rm -f $(DESTDIR)$(libdir)/test.la