summaryrefslogtreecommitdiff
path: root/plugin/vst/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/vst/Makefile.am')
-rw-r--r--plugin/vst/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/plugin/vst/Makefile.am b/plugin/vst/Makefile.am
index 0f3df84..be45282 100644
--- a/plugin/vst/Makefile.am
+++ b/plugin/vst/Makefile.am
@@ -40,7 +40,8 @@ public.sdk/source/vst2.x/vstplugmain.cpp: public.sdk/source/vst2.x @VST_SOURCE_P
cp @VST_SOURCE_PATH@/public.sdk/source/vst2.x/vstplugmain.cpp $@
# Hack to compile vst sources without -Wall -Werror
-libvstsdk_la_CXXFLAGS = -w $(VST_CPPFLAGS) -Ipublic.sdk/source/vst2.x -I.
+libvstsdk_la_CXXFLAGS = -Wno-c++11-narrowing -w $(VST_CPPFLAGS) \
+ -Ipublic.sdk/source/vst2.x -I.
nodist_libvstsdk_la_SOURCES = \
public.sdk/source/vst2.x/audioeffectx.cpp \
@@ -60,4 +61,4 @@ CLEANFILES = \
clean-local:
-rm -rf public.sdk pluginterfaces
-#pluginterfaces/vst2.x/vstfxstore.h \ No newline at end of file
+#pluginterfaces/vst2.x/vstfxstore.h